跳至主要內容

Windows安装

五六零网校小于 1 分钟

前提条件

  • 安装Node.js,要求版本必须大于v18及以上
  • 包管理器: npm >= 8、yarn >= 2 或 pnpm >= 7

安装教程

  1. 在任意位置,创建项目文件夹

  2. 打开Windows PowerShell ,进入项目文件夹

Alt text
Alt text
  1. 确认node和npm的版本
node -v
npm -v
Alt text
Alt text
  1. 输入命令安装
npm init vuepress-theme-hope 
  1. 根据程序界面进行安装。

可参考以下设置:

安装界面
安装界面
选项说明
   - 语言:简体中文
   - 包管理器: npm (推荐)
   - 应用名称:自填(注意只能英文)
   - 版本:1.0.0
   - 应用描述:可留空(在主题设置内可修改)
   - 设置协议MIT:不填(按回车键下一步)
   - 是否需要多语言: N (选Y,会按每个语言构建多个目录)
   - Github工作流: N
   - 创建项目的类型:Docs (推荐)
   - 使用源:国内镜像源(推荐)

更换安装源

注意

如果安装卡住或者无法访问npm的安装源,可将npm的安装源换成淘宝的源,再进行安装

更换npm源为淘宝源

npm config set registry https://registry.npm.taobao.org/